Yunit packages for debian unstable

After almost two months of work, we are pleased to announce that Yunit is now available as an overlay repository for debian unstable (64bit).

Installation instructions

For the following steps we assume that you have already a debian unstable installation configured with gnome or XFCE desktop environment. Probably it will work if you are currently using other desktop environments but we haven’t tested it yet.

As root execute the following commands

1
2
3
4
5
  wget -qO - http://archive.yunit.io/yunit.gpg.key | apt-key add -
  echo 'deb http://archive.yunit.io/debian/ unstable main' > /etc/apt/sources.list.d/yunit.list
  apt update
  apt upgrade
  apt install unity8-desktop-session unity8-greeter

if asked, choose lightdm as display manager.

Known issues

As a general note this is considered alpha quality software and you should expect many issues and/or crashes. Currently we are aware of the following issues.

  • Gnome wayland cannot be started from unity 8’s greeter.
    We are currently working to fix it.
  • There are no settings for configuring online accounts
    We are currently working to fix it.
    Update (June 5): Seems that this issue is related to ubuntu’s kernel that has some additional patches regarding apparmor’s security. We have confirmed that with ubuntu’s kernel compiled in debian, online accounts work correctly. Obviously we don’t want to ship a patched kernel along yunit’s packages and we are currently looking for other solutions/workarounds.
  • Libertine containers don’t work as they depend on lxd which is not packaged for debian, yet.
  • Running it in a VirtualBox machine may or may not work.
    In our testing environment we were able to run it under VirtualBox, however, as reported by some testers, it may not always be the case (we are unsure why).

We need your feedback!

We are looking forward to hear your feedback. If something doesn’t work for you please let us know preferably via our forum.

FAQ

Why debian?

In this initial phase of the project, we needed to make sure that we understand yunit and all of its dependencies. Debian was a perfect choice to do so, as it is the base of ubuntu, so we are in a similar environment.

Will you make it available for ubuntu?

We plan to do so! Our immediate plans is to backport it to ubuntu 16.04, as it will help UBPorts to migrate forward from 15.04 to 16.04.

17 thoughts on “Yunit packages for debian unstable”

  1. Hello jsalatas, thank you for this gift for us Unity users. A very glad news on June 2nd. I hope I can try Yunit soon.

  2. Hi jsalatas, many thanks for this great project for us Unity-lovers. I will test it soon and will give feedback via forum. Keep on rocking!

  3. <3 ~just heard about ubuntu dropping Unity Oo ….good to see it may live on 🙂

    (((I just started using it recently, about half a year ago, and really came to like it <:) ….~I know u most certainly have lot's of things to do atm, but about the only thing, that really annoyed me, is that keyboard-shortcuts aren't freely configurable (cuz unity has some keys deeply ingrained, it seems)))) ~ GL & HF !! ~

    * <3 *

    1. At the moment it is the same code. However as we will start fixing things and moving forward, the code will evolve. In any case we wanted a different name to avoid any potential trademarks etc.

      1. Did you not tried to get in touch with Canonical, to talk about that trademark stuff?
        Once I contacted them about merchandising stuff, they answered me very quick.

  4. Just as I started to appreciate Unity, Ubuntu decides to drop it as its standard DE.
    Glad to see a community such as yours continuing development on this DE.
    Best of luck! Looking forward to installing it in Debian Testing or Stable soon.

  5. Hi

    Huge thanks to everyone working on this: I still can’t understand Canonical’s decision: convergence is such a good idea.

    I am currently running Unity8 on my very old 32-bit MacBook. I am wondering if there will be a version of Yunit to download (easily – I’m not really a techie) before 17.10 is released?

  6. Thank you – to everyone – for all the work that’s being done on yUnit. I really loved the quest for the Holy Grail that is convergence, and was dismayed that Canonical decided to pull the plug on it, just as it was beginning to shape up.

    I use Unity8 quite a lot, and I hope to be able to continue using it as yUnit once there is an easy install iso – I’m not really a techie. Will yUnit eventually become Core and Snap? And if so, will there be a 32-bit core for older machines?

  7. If you are building packages on debian, what stopping you building for i386 as well? It’s all about adding a architecture debian/control. Unity8 (last-known-condition) builds on ubuntu well both for 32 & 64 bit.

    1. Actually the only issue we are currently having is our limited time and resource. Hope that after some time we would have more people involved and hopefully some of them might be interesting in building and maintaining packages for 32bit architectures

  8. Hi, in debian buster (testing) not install Yunit. Look:

    sudo apt install unity8-desktop-session unity8-greeter
    Lendo listas de pacotes… Pronto
    Construindo árvore de dependências
    Lendo informação de estado… Pronto
    Alguns pacotes não puderam ser instalados. Isto pode significar que
    você solicitou uma situação impossível ou, se você está usando a
    distribuição instável, que alguns pacotes requeridos não foram
    criados ainda ou foram retirados da “Incoming”.
    A informação a seguir pode ajudar a resolver a situação:

    Os pacotes a seguir têm dependências desencontradas:
    unity8-desktop-session : Depende: mir-graphics-drivers-desktop mas não será instalado
    Depende: qtmir-desktop mas não será instalado
    Depende: qtubuntu-appmenutheme mas não será instalado
    Depende: qtubuntu-desktop mas não será instalado
    Depende: unity-system-compositor mas não será instalado
    Depende: unity8 mas não será instalado
    Depende: url-dispatcher mas não será instalado
    Recomenda: indicator-transfer mas não será instalado
    Recomenda: qtubuntu-print mas não é instalável
    Recomenda: ubuntu-terminal-app mas não será instalado
    Recomenda: unity-scope-mediascanner2 mas não será instalado
    Recomenda: webbrowser-app mas não será instalado
    unity8-greeter : Depende: unity8 (= 8.15+17.04.20170618-0yunit0+debian+9) mas não será instalado
    Depende: unity-system-compositor mas não será instalado
    E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.

Leave a Reply

Your email address will not be published. Required fields are marked *